Microsoft Excel/Logisch

Uit Wikibooks
Naar navigatie springen Naar zoeken springen

Logische formules worden gekenmerkt dat ze allemaal met de twee waarden "WAAR" en "ONWAAR". Hieronder zullen we een aantal veelgebruikte logische formules geven. Omdat er verschil is tussen de waarde WAAR en de formule WAAR, Zullen we de formulles op deze pagina aangeven met twee haakjes erachter (WAAR = de waarde, WAAR() = een formule).

WAAR en ONWAAR[bewerken]

WAAR en ONWAAR doen eigenlijk precies wat er staat. Ze geven de waarde WAAR (voor de formule WAAR() ) en ONWAAR (voor de formule ONWAAR() ). Je gebruikt deze formules als volgt.

 =WAAR()
=ONWAAR() 

NIET[bewerken]

NIET() werkt heel simpel. Deze formule maakt van iedere waarde WAAR, ONWAAR. En van iedere waarde ONWAAR maakt hij de waarde waar.

=NIET(waarde)

EN en OF[bewerken]

EN() en OF zijn twee formulles om te controleren of waarden waar zijn of niet. EN() gebruikt men om te controleren of alle waarden die als argument zijn opgegeven waar zijn. Als dit zo is zal er uit de formule EN() ook WAAR uitkomen. Zit er bij een van de waarde ONWAAR tussen dan zal de uitkomst ONWAAR zijn. OF() werkt eigenlijk precies andersom. Bij of hoeft er namelijk maar een waarde WAAR tussen te zitten om als uitkomst WAAR te geven. Als alle waarden ONWAAR zijn zal de uitkomst ONWAAR zijn. Men gebruikt deze formulles op de volgende manier.

 =EN(waarde1;waarde2;..;..)
=OF(waarde1;waarde2;..;..)

Omdat je in totaal bij beide formulles 255 argumenten in kan voeren ga ik ze niet allemaal opschrijven. In plaats daarvan zet ik twee keer twee puntjes om te laten zien dat op die puntjes je op de zelfde manier waarden invult als daarvoor staat.

ALS[bewerken]

ALS() is de meestgebruikte formule van de logische formules. Met als kan men testen ofdat er aan een bepaalde bewering is voldaan. Bovendien kan men ook nog een waarde geven voor als de bewering WAAR is of voor als de bewering ONWAAR is. Men gebruikt ALS() alsvolgt.

=ALS(bewering;waarde-voor-als-bewering-is-waar;waarde-voor-als-bewering-is-onwaar)

Een voorbeeld

A B C
1 5 3 0
2 =ALS(A1<B1;C2;C1) 1

In dit geval zal er in cel A2 de waarde 0 komen te staan. Want 5 is niet kleiner dan 3, dus de formule neemt de waarde aan van C1.

Informatie afkomstig van http://nl.wikibooks.org Wikibooks NL.
Wikibooks NL is onderdeel van de wikimediafoundation.